Monday, October 1, 2007

Bad Variable Names

A few months back I posted about how to choose variable names. Since then I've had up on my white board, based on some real world variable names we've encountered, some sample bad variable names. It then morphed into visitors trying trying to come up with the worst variable name ever. The current rendition is:

if not IsNotCanNotUnDisable then
Result := not UnTrue;

What bad variable names have you encountered?


Unknown said...

I can across this code in our app written by someone:

for kx := 1 to param_list.Count - 1 do begin
bugs_bunny := StrToDate(param_list[kx]);
bugs_bunny := 0;
if bugs_bunny > tweety_bird then
tweety_bird := bugs_bunny;

I've never seen bugs_bunny and tweety_bird used a variables before. :)

Chris Bensen said...


Those are some great variable names. I wish I came up with them first :)

Anonymous said...

That is just so doubleplusungood...

Anonymous said...


It must have been a chick to write that :)

Anonymous said...

NotIsNotCanNotUnDisable has a challenger...

Check out this tale of woe, published on worsethanfailure yesterday.

Anonymous said...

And here is another one...

Post a Comment